New Banner 3

Services

Find out more about ProCheckUp's services including: Penetration Testing, PCI QSA and PCI ASV

PR08-23

PR08-23 - XSS on Novell GroupWise WebAccess

ProCheckUp Labs

ProCheckUp Labs are dedicated to conducting research and raising the awareness of information security issues. The combination of ProCheckNet's response-driven AI technology and our experienced security consultants has led to the discovery of many security vulnerabilities and advisories during penetration testing assignments.

In 2008 ProCheckUp published more vulnerabilities than any other UK penetration testing company.

Over the years, ProCheckUp have been credited with finding vulnerabilities and advisories in products from vendors such as:  

Microsoft - Aruba Networks - IBM - Novell - BEA Systems - Whale Communications - Netscape - Hummingbird - Apache- F5 Networks - GoAhead - Sun Microsystems

Advisories (Vulnerabilities) & Papers

Vulnerability found:
02 October 2008
Vendor informed:
03 October 2008
Severity level:
Medium
Credits:
Richard Brain of ProCheckUp Ltd (www.procheckup.com). ProCheckUp thanks Novell for working with us in such a professional manner.
Description:
Novell GroupWise WebAcces is vulnerable to a vanilla XSS (non-persistent) via POST requests. Although filtering takes place for GET requests, POST requests are ignored.

Vulnerable server-side script: '/gw/webacc',
Unfiltered parameter: 'User.id', 'Library.queryText'

Sucessfully tested on

Novell GroupWise WebAccess 7.0.3

Novell has confirmed the following versions to be affected by this vulnerability:

GroupWise 6.5x
GroupWise 7.0, 7.01, 7.02x, 7.03
GroupWise 8.0 (shipping 8.0 release only)

CVE reference

CVE-2009-0273

Consequences

An attacker may be able to cause execution of malicious scripting code in the browser of a victim user who visits a malicious third-party page. Such code would run within the security context of the target domain.

This type of attack can result in non-persistent defacement of the target site, or the redirection of confidential information (i.e.: session IDs, address books, emails) to unauthorised third parties.
Proof of concept:
As kindly requested by Novell, ProCheckUp will delay publication of the PoC details to allow GroupWise customers time to apply the recommended security patches.
How to fix:
http://www.novell.com/support/search.do?usemicrosite=true&searchString=7002321
References:
http://www.procheckup.com/vulnerability_manager

http://en.wikipedia.org/wiki/Cross-site_scripting
Legal:
Copyright 2009 ProCheckUp Ltd. All rights reserved.

Permission is granted for copying and circulating this Bulletin to the Internet community for the purpose of alerting them to problems, if and only if the Bulletin is not changed or edited in any way, is attributed to ProCheckUp indicating this web page URL, and provided such reproduction and/or distribution is performed for non-commercial purposes.

Any other use of this information is prohibited. ProCheckUp is not liable for any misuse of this information by any third party. ProCheckUp is not responsible for the content of external Internet sites.

Back to Vulnerabilities List